Tuesday, October 30, 2007

Flat on my back...

That's where I have been since Friday, they gave me mis.pros.tol to induce the miscarriage. It was incredibly painful the first night. It was not a fun weekend. Had a f/u u/s on Monday to see if the gestational sac had passed. It had not. Another round of the drug for another 48 hours. Currently doing that and lots of tyle.nol 3.

I am very tired and have extreme cramps and finally alot of bleeding. Another u/s on Friday to make sure all is clear. Followed by weekly blood draws to monitor dropping of hcg.

The RE told me not to speculate too much about the future. They need testing to confirm the problem and then we'll take it one step at time from there. I need to wait 6-8 weeks following a zero beta to start testing.

It looks like it will be a long winter, and likely well into the new year before we can get any firm answers or start another cycle. Thanks again for so many encouraging comments. It has helped more than you will ever know.

5 comments:

Chas said...

My sister in law just started that drug last night, and she's been in a lot of pain. I'm so sorry you're going through this again. I'm thinking of you!

Honeycutt Family said...

It just really, really sucks that you have to go through this AGAIN! I'm so sorry. Praying for you...
Jen

Fertilize Me said...

thinking of of you and sending you virtual hugs

Kate said...

Again, I am so sorry. I will be thinking of you and hoping that the Dr.s can provide you with some answers.

Mommy Someday said...

So sorry your are having to go through this!!